Konfigurasi OSPF Multi Area

Hai blogger, sebelumnya saya udah ngebahas soal konfigurasi OSPF single area. Kali ini saya mau membahas tentang routing protocol ospf multi area.

Konfigurasi ini diperlukan apabila terdapat area yang berbeda dan kita memerlukan komunikasi data. Topologinya seperti gambar

 

Topologi OSPF Multi Area

Topologi OSPF Multi Area

Pada topologi ini, kita bagi menjadi 3 area, yaitu Area 0, Area 1 dan Area 2

Area 0 : antara R1 – R2

Area 1 : antara R2 – R3

Area 2 : antara R2 – R4

Internal Router = R1, R3, R4 –> semua interface berada pada area yang sama

Area Border Router (ABR) = R2 –> berfungsi menghubungkan dua area yang berbeda

Backbone Router = R1, R2 –> area yang terkoneksi ke area 0, disebut juga area 0.0.0.0

IP address s0/0/0 R1 = 12.12.12.1/30

IP address s0/0/0 R2 = 12.12.12.2/30

IP address S0/1/0 R2 = 23.23.23.2/30

IP address S0/1/1 R2 = 24.24.24.2/30

IP address S0/0/0 R3 = 23.23.23.1/30

IP address S0/0/1 R4 = 24.24.24.1/30

 

Konfigurasi pada R1 :

Building configuration…

Current configuration : 781 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 12.12.12.1 255.255.255.252
clock rate 2000000
!
interface Serial0/0/1
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
router ospf 1
log-adjacency-changes
network 1.1.1.0 0.0.0.255 area 0
network 12.12.12.0 0.0.0.3 area 0
!
ip classless
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end

Konfigurasi pada R2 :

Building configuration…

Current configuration : 1087 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R2
!
!
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface Loopback0
ip address 2.2.2.1 255.255.255.0
!
interface Loopback1
ip address 5.5.5.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 12.12.12.2 255.255.255.252
!
interface Serial0/0/1
no ip address
shutdown
!
interface Serial0/1/0
ip address 23.23.23.2 255.255.255.252
clock rate 2000000
!
interface Serial0/1/1
ip address 24.24.24.2 255.255.255.252
clock rate 2000000
!
interface Vlan1
no ip address
shutdown
!
router ospf 2
log-adjacency-changes
network 2.2.2.0 0.0.0.255 area 0
network 5.5.5.0 0.0.0.255 area 0
network 12.12.12.0 0.0.0.3 area 0
network 23.23.23.0 0.0.0.3 area 1
network 24.24.24.0 0.0.0.3 area 2
!
ip classless
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end

Konfigurasi pada R3 :

Building configuration…

Current configuration : 761 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface Loopback0
ip address 3.3.3.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 23.23.23.1 255.255.255.252
!
interface Serial0/0/1
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
router ospf 3
log-adjacency-changes
network 3.3.3.0 0.0.0.255 area 1
network 23.23.23.0 0.0.0.3 area 1
!
ip classless
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end

Konfigurasi pada R4 :

Building configuration…

Current configuration : 761 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R4
!
!
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface Loopback0
ip address 4.4.4.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
no ip address
shutdown
!
interface Serial0/0/1
ip address 24.24.24.1 255.255.255.252
!
interface Vlan1
no ip address
shutdown
!
router ospf 4
log-adjacency-changes
network 4.4.4.0 0.0.0.255 area 2
network 24.24.24.0 0.0.0.3 area 2
!
ip classless
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end

Leave a Reply

Your email address will not be published. Required fields are marked *